Product Images Degraded Performance
Incident Report for Nosto
Postmortem

On Tuesday 28th of February approximately 18:10 (UTC), Nosto’s incident response team was alerted by degenerated performance affecting product images in our on-site and email features. The root cause of the problem was soon, approximately 18:24 (UTC), identified as Nosto’s infrastructure provider. The incident prevented Nosto to show some product images in on-site and email features during the period of the incident. The share of images that were affected was relatively small (<10%) and the issue did not affect all Nosto customers. Email delivery was also temporarily delayed during the time of the incident.

Our Infrastructure provider restored the services and all Nosto features were fully functional approximately by 23:30 (UTC), March 1st 2017.

We are sorry for the performance issues and possible extra trouble caused by the incident.

Posted over 2 years ago. Mar 01, 2017 - 09:01 UTC

Resolved
Our upstream provider has fixed the issue and we are fully operational again.
Posted over 2 years ago. Feb 28, 2017 - 23:32 UTC
Update
Product image serving is working again since 30 minutes ago. Product image updates during last 3 hours have not yet been processed as our upstream provider is still having issues related to uploading new files.
Posted over 2 years ago. Feb 28, 2017 - 21:35 UTC
Identified
We have identified the issue in being with an upstream provider. They have acknowledged the issue and are actively working on remediating the issue.
Posted over 2 years ago. Feb 28, 2017 - 18:24 UTC
Investigating
We are investigating reports of degraded performance and issues with product images.
Posted over 2 years ago. Feb 28, 2017 - 18:11 UTC