Admin panel is down
Incident Report for Nosto
Resolved
This incident has been resolved.
We are actively monitoring the situation.
Posted Feb 22, 2023 - 15:00 UTC
Investigating
We are currently investigating this issue.
Posted Feb 22, 2023 - 14:57 UTC
This incident affected: Admin panel.